No components marked as affected
Resolved
This incident has been resolved.
Investigating
We are pleased to announce that the issue regarding the elevated decline rates on WeTravel Cards has been successfully resolved.
Investigating
We are investigating reports of elevated card decline rates with our WeTravel Cards issuing partner. We have escalated to our card-issuing partner and will update as soon as possible. All other components of WeTravel are operational.