Issues with WeTravel Card Service
Resolved·Partial outage

This incident has been resolved.

Fri, Dec 15, 2023, 10:29 AM
(2 years ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Fri, Dec 15, 2023, 10:29 AM

Investigating

We are pleased to announce that the issue regarding the elevated decline rates on WeTravel Cards has been successfully resolved.

Thu, Dec 14, 2023, 10:28 AM(1 day earlier)

Investigating

We are investigating reports of elevated card decline rates with our WeTravel Cards issuing partner. We have escalated to our card-issuing partner and will update as soon as possible. All other components of WeTravel are operational.

Tue, Dec 12, 2023, 08:21 PM(1 day earlier)
Powered by