Issues with file upload on WeTravel
Incident Report for WeTravel System
Resolved
This incident has been resolved.
Posted Aug 06, 2024 - 13:35 UTC
Investigating
We are currently investigating issues related to uploading files (documents, images, etc.) on WeTravel with our cloud service providers.
Posted Aug 06, 2024 - 10:46 UTC
This incident affected: Platform (Management Portal).