Issues affecting payments and transfers on WeTravel

Incident Report for WeTravel System

Resolved

The issue affecting some payments and wire transfers has been resolved, and all services are now operating normally. We apologize for the interruption and appreciate your patience.
Posted May 05, 2025 - 14:15 UTC

Identified

We're aware of an issue impacting some payments and wire transfers, related to one of our payment partners. We're actively monitoring the situation and will share updates as resolution efforts continue.
Posted May 05, 2025 - 14:06 UTC

Investigating

We're currently investigating issues affecting payments and wire transfers. Our team is working to resolve this as quickly as possible and will share updates as we have them.
Posted May 05, 2025 - 13:53 UTC
This incident affected: Platform (Payment processing).