Issues with file upload on WeTravel

Incident Report for WeTravel System

Resolved

The file upload issue has been resolved. Trip creation, bookings requiring document uploads, and itinerary file/image uploads are now working as expected.
Posted Apr 07, 2025 - 10:59 UTC

Investigating

We're currently experiencing issues with file uploads due to a problem with our provider. This is impacting trip creation, bookings that require document uploads, and itinerary file or image uploads. We're actively investigating and working on a fix.
Posted Apr 07, 2025 - 10:33 UTC
This incident affected: Platform (Management Portal).